Debian serwer na U1A

Na stronie
https://romanrm.net/a10/debian znalazłem ciekawy opis instalacji na MK802ii i postanowiłem uruchomić to na U1A.
Problem polegał na tym, że nie posiadam wspomnianej w opisie karty sieciowej na USB.
Instrukcję wykonałem zgodnie z opisem, ale przed instalacją wyedytowałem 2 pliki na karcie pamięci.

Uwaga. Testowanie procedur (zaleceń/czegokolwiek) z tej strony niesie ryzyko uszkodzenia Twojego urządzenia. Jeżeli wykonasz instrukcję/skrypty/cokolwiek z tej strony, to robisz to wyłącznie na własną odpowiedzialność!
Zostałeś ostrzeżony/Zostałaś ostrzeżona!

Niezbyt dokładnie cytując fragment strony WWW gry Danger from the Deep: Urządzenie może wypić Twoje mleko, czy ukraść Ci kota ;)

Operacja wyglądała mniej więcej tak (jako root, lub pamiętając o sudo)
sdX należy zastąpić odpowiednio dla swojej karty pamięci, na której uprzednio został zainstalowany Debian według opisu z przytoczonej wcześniej strony (liczba 2 w instrukcji poniżej oznacza drugą partycje na karcie, najlepiej kartę wyjąć po zakończeniu wykonywania opisu ze strony https://romanrm.net/a10/debian, i podłączyć ponownie do kompa, aby system wykrył na niej partycje)
mount /dev/sdX2 /media/sdX2
następnie w pliku /etc/network/interfaces dodałem treść podobną do tej poniżej:

auto wlan0
iface wlan0 inet dhcp
wpa-ssid NazwaSieciBezprzewodowej
wpa-psk MójKluczWPA/WPA2

Dodatkowo, ponieważ nie byłem pewien, czy powyższe zadziała (zawsze mogło brakować wireless-tools, firmware karty/modułu), a posiadam „przejściówkę” usb-com, w pliku /etc/inittab zadbałem o konsolę na porcie szeregowym ttyUSB0, podmieniając urządzenie ttyS0 na ttyUSB0.
T0:23:respawn:/sbin/getty -L ttyUSB0 115200 vt102

Zostaw odpowiedź

XHTML: Możesz użyć tagów:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>

Uwaga ciasteczka
Strona używa plików cookie. Ustawienia odnośnie owych plików znajdziesz w opcjach swojej przeglądarki